Eskling's picture

Samsung Galaxy Tab Incompatible

The iSpot app is incompatible with the Samsung Galaxy Tab (Android 4.1.1) and will not install.

Reply

Comments

Jonathan's picture

Thanks for letting us know.

Thanks for letting us know. We will see if we can fix this at the next upgrade.

Jonathan
University of Edinburgh and Biodiversity Observatory (OU)